ConPresso Community

Fragen, Antworten, Diskussionen rund um das Content Management System ConPresso

 
Problem bei Absender-Adresse

 
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Modul Kontakt (ConPresso 4)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Marky
ConPresso-Checker


Anmeldungsdatum: 11.12.2005
Beiträge: 382

BeitragVerfasst am: 29.01.2006 13:10    Titel: Problem bei Absender-Adresse Antworten mit Zitat

Hallo Rainer,

ich habe Dein Modul installiert und es funktioniert fast alles wie erwartet.
Jetzt habe ich zunächst trotzdem noch ein Problem damit und zum anderen eine Anregung dazu.

System: PHP/4.4.1 auf SuSE Linux 8.2

1. Problem
Wenn ich eine Mail über das Formular verschicke, wird nicht die Absender-Mailadresse in der Mail eingetragen, die ich im Modul konfiguriert habe, sondern es steht als Ansender wwwrun@myDomain.de drin. wwwrun ist ja der Webserver-User und wir dann eingesetzt, wenn kein Absender zum Mailversand ermittelt werden kann. Aber das sollte ja gerade der im Modul konfigurierte Eintrag sein.
Die Adresse, die ich im Modul konfiguriere ist ein gültige Adresse, d.h. der Mailsserver kennt sie. Wenn ich mir von Conpresso z.B. mein Passwort zurücksetzen lasse, dann erhalte ich eine Mail mit dem bei den Conpresso-Systemeinstellungen eingetragenen Systemabsender, also z.B. webmaster@myDomain.de. Deshalb wundert mich das Problem etwas, da es ja dann eigentlich keine ungünstige Mailservereinstellung sein kann ?!

2. Anregung
Du hast lediglich drei Eingabefelder als Pflichtfelder fest codiert. Siehst Du in einer zukünftigen Version eine Möglichkeit, alle Parameter optional als Pflichtfelder deklarieren zu können oder könnte man vielleicht bei den Einstellungen die Möglichkeit zur Eingabe von Javascript-Code vorsehen, welcher bei Vorhandensein in das Attribut 'OnSubmit' im Form-Tag eingetragen wird. Damit hätte man eine maximale Flexibilität, was die Validierug betrifft.
Du hattest zwar erwähnt, dass das Modul zunächst für den internen Einsatz vorgesehen war, allerdings wäre das schon eine sehr vorteilhafte Eweiterung.




Gruß
Markus
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
semf
Modul-Entwickler


Anmeldungsdatum: 01.01.1970
Beiträge: 1853
Wohnort: Gütersloh-Friedrichsdorf

BeitragVerfasst am: 29.01.2006 13:18    Titel: Antworten mit Zitat

Hallo Marky!

Wann hast du das Modul runtergladen? Der Absender-Bug sollte eigentlich mittlerweile behoben sein!?

Die nächste Version ist in gedanklicher und programmiertechnischer Umsetzung. Dabei sieht es ganz danach aus, das sich das komplette
Modul von der Funktion her ändern wird. Dann soll auch sowas wie
Javascript-Code o.ä. möglich sein.

_________________
Viel Erfolg!

Module ConPresso 4.x
Latest News
Tell-a-friend

Module ConPresso 3.4.x
Index_X
Kontakt
RSS-Feed
Umfrage
Gästebuch
Tell-a-Friend

Modul-Download
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Marky
ConPresso-Checker


Anmeldungsdatum: 11.12.2005
Beiträge: 382

BeitragVerfasst am: 29.01.2006 14:20    Titel: Antworten mit Zitat

Der Download war am 22.01.2006 ...

Gruß
Markus
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
semf
Modul-Entwickler


Anmeldungsdatum: 01.01.1970
Beiträge: 1853
Wohnort: Gütersloh-Friedrichsdorf

BeitragVerfasst am: 29.01.2006 19:23    Titel: Antworten mit Zitat

Hallo Salox,

lade das Zip-File erneut runter und ersetzt im Modul im Ordner _includes
die Datei index.inc.php durch die aus dem Zip-File. Damit sollte das Abesenderproblem gelöst sein!

Zu dem Sprachen-Problem kann ich nichts sagen - das richtet sich eigentlich immer nach der eingestellten Systemsprache. Du kannst aber im Template mal testweise den Platzhalter "<!-- Contact: Lastname_error; --> durch einen Text ersetzten - sollte auch gehen.

_________________
Viel Erfolg!

Module ConPresso 4.x
Latest News
Tell-a-friend

Module ConPresso 3.4.x
Index_X
Kontakt
RSS-Feed
Umfrage
Gästebuch
Tell-a-Friend

Modul-Download
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Marky
ConPresso-Checker


Anmeldungsdatum: 11.12.2005
Beiträge: 382

BeitragVerfasst am: 29.01.2006 22:17    Titel: Antworten mit Zitat

Hi,

der Fehler beim Mailversand ist mit dem Update behoben.
Besten Dank dafür!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Modul Kontakt (ConPresso 4) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen