ConPresso Community

Fragen, Antworten, Diskussionen rund um das Content Management System ConPresso

 
versand der emails aus kontaktformular funktioniert nicht

 
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Modul Kontakt (ConPresso 4)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
baluo
ConPresso-Experte


Anmeldungsdatum: 14.11.2005
Beiträge: 607

BeitragVerfasst am: 07.05.2008 12:09    Titel: versand der emails aus kontaktformular funktioniert nicht Antworten mit Zitat

ich habe ein merkwuerdiges problem mit dem kontaktformular:

vermutlich seit umstellung der datenbank und der gesamten cpo-dateien aus einem unterverzeichnis in das rootverzeichnis funktioniert der versand der emails aus einem mehrfach installierten kontaktformular nicht mehr, z.b. hier:
http://www.dw-dith.de/mod_contact/index.php?rubric=service_schreiben.

konkret:
das eintragen und absenden der email aus dem kontaktformular funktioniert anstandslos, die bestaetigungsseite wird ausgegeben und eine kopie der versandten email geht auf meinem privaten email-account ein.
die eigentlichen empfaenger im bereich der <dw-dith.de>-domain erhalten aber keine der nachrichten.

hat das was mit conpresso zu tun - und wenn ja, wo und wie ? - oder mit einem rigorosen spam-filter ?

danke und gruss
gerhard
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7023

BeitragVerfasst am: 07.05.2008 12:42    Titel: Antworten mit Zitat

Das kannst Du Dir selbst ausrechnen.

Der Mailversand funktioniert ja und alles andere auch.

Nur der Mailserver akzeptiert keine Mails von seiner eigenen Domain.
Gründe können sein:
- der Absender existiert nicht
- der Absender ist kein erlaubter Versender
- der Mailserver akzeptiert keine Mails, die er nicht selbst versendet hat

Nun wendest Du Dich am besten an den Server-Administrator und lässt die Mail-Protokolle analysieren.

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7

 
Für dieses Posting bedanken sich die folgenden User: baluo
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
baluo
ConPresso-Experte


Anmeldungsdatum: 14.11.2005
Beiträge: 607

BeitragVerfasst am: 17.05.2008 00:29    Titel: Antworten mit Zitat

dies uebrigens war die info meines host-admins:

"Der Mailserver hat den PHP Befehl "Mail" nicht akzeptiert.
Es lag an einem Fehler auf dem Mailserver."

der mailversand funktioniert jetzt. danke
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
René Märtin
ConPresso-Newbie


Anmeldungsdatum: 22.04.2007
Beiträge: 20

BeitragVerfasst am: 11.11.2008 14:27    Titel: Gleiches Problem Antworten mit Zitat

Ich habe das gleiche Problem (glaube ich jedenfalls). Bis vor kurzem ging es noch, nun werden aber keine Mails mehr versandt. Mein Provider (Host Europe) antwortet folgendes:
Zitat:
Damit per PHP E-Mails versendet werden können, muss eine gültige Absenderadresse angegeben werden.

Soll über PHP eine E-Mail versendet werden, muss mit dem Parameter "-f" eine gültige Absenderadresse angegeben werden. Bitte beachten Sie, dass diese E-Mail-Adresse innerhalb des WebPacks angelegt sein muss! Die Syntax lautet "-f absender@hier-bitte-ihren-domainnamen-einsetzen.de". Fehlt diese Information kann kein Mailversand erfolgen und die mail()-Funktion liefert eine Fehlermeldung.

Dieser Parameter muss der E-Mail-Funktion im PHP-Quelltext übergeben werden. Dies könnte z.B. so aussehen:
mail ($empfänger, $betreff, $nachricht, $headers, "-f absender@hier-bitte-ihren-domainnamen-einsetzen.de");


Ich habe eine gültige E-Mail-Adresse angegeben, die innerhalb des gleichen Pakets läuft, in dem auch das Kontakt-Modul installiert ist.

An welcher Stelle passe ich das an? Oder bin ich auf der falschen Fährte?
Gruß, René
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7023

BeitragVerfasst am: 11.11.2008 16:51    Titel: Antworten mit Zitat

_includes/index.inc.php

Hier suchst Du die zwei Zeilen, in denen @mail vorkommt und setzt direkt hinter $mailheader das geforderte
Code:

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7

 
Für dieses Posting bedanken sich die folgenden User: René Märtin
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
René Märtin
ConPresso-Newbie


Anmeldungsdatum: 22.04.2007
Beiträge: 20

BeitragVerfasst am: 12.11.2008 14:22    Titel: Antworten mit Zitat

... funktioniert jetzt alles wieder wunderbar. Danke für den Tipp.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Modul Kontakt (ConPresso 4) Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen