ConPresso Community

Fragen, Antworten, Diskussionen rund um das Content Management System ConPresso

 
parse error bei installation 4.1.5

 
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Installation ConPresso 4
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Ulrich Krause
ConPresso-User


Anmeldungsdatum: 27.02.2007
Beiträge: 41
Wohnort: 63075 Offenbach

BeitragVerfasst am: 25.11.2012 15:48    Titel: parse error bei installation 4.1.5 Antworten mit Zitat

"Parse error: syntax error,
unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}'
in /homepages/7/d216873517/htdocs/_include/anti_csrf.inc.php on line 19"

diese Meldung erhalte ich bei der Neuinstallation von 4.1.5. als Meldung auf der Seite 3/3 Schritte.

Gibt es eine Lösung?

Uli
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7023

BeitragVerfasst am: 25.11.2012 16:11    Titel: Antworten mit Zitat

Zitat:
Gibt es eine Lösung?

PHP-Version < 5 ???

siehe http://community.conpresso.de/viewtopic.php?p=27279#27279
Zitat:
Minimum sollte im Moment ein PHP5 sein. PHP 4 sollte man aus Sicherheitsgründen schon nicht mehr einsetzen. Im 4.1er Zweig von CPO werden objektorientierte Funktionen von PHP 5 eingesetzt, so dass das auch die minimale Version hierfür sein sollte.

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Ulrich Krause
ConPresso-User


Anmeldungsdatum: 27.02.2007
Beiträge: 41
Wohnort: 63075 Offenbach

BeitragVerfasst am: 25.11.2012 17:02    Titel: 4.1.5 mit php 5.2 das läuft Antworten mit Zitat

Hallo, Markus,
ich bin bei 1und1 und dort kann man die PHP-Version 4, 5.2 oder 5.4 einsellen.
Bei 5.2 gibt es den Fehler nicht mehr.
Danke für die schnelle Reaktion.
Uli Very Happy
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
toemmel
ConPresso-Newbie


Anmeldungsdatum: 28.01.2013
Beiträge: 1

BeitragVerfasst am: 29.01.2013 12:38    Titel: Antworten mit Zitat

Bekomme bei der Installation von Conpresso ebenfalls die Fehlermeldung, auf unserem Webserver läuft PHP4.

Gibt es hier einen "Workaround" um Conpresso 4.1.5. auch mit PHP4 zum Fliegen zu bekommen? Hintergrund: Derzeit läuft unsere Webseite noch unter Conpresso 3.x und ich möchte Conpresso 4.1.5 parallel installieren und nach ausgiebigen Tests umschalten.

Daher ist die Umschaltung auf PHP5 (derzeit noch) nicht möglich.

Schöne Grüße
Toemmel
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7023

BeitragVerfasst am: 29.01.2013 12:42    Titel: Antworten mit Zitat

Benutze 4.0.12. Der 4.1.x-Zeig läuft NICHT mit PHP4.

Ich nutze 3.4.8 mit PHP 5.2.6, warum sollte eine Nutzung von PHP <5.4 nicht möglich sein?

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
balu
ConPresso-Entwickler


Anmeldungsdatum: 01.01.1970
Beiträge: 1746

BeitragVerfasst am: 30.01.2013 13:05    Titel: Antworten mit Zitat

Das Update der Datenbank von 4.0 auf 4.1 ist dann sehr einfach mit einem Script durchgeführt.

Wenn also nicht PHP5 < 5.4 geht, könnte man erst 4.0 nehmen und dann auf 4.1 updaten.

Balu

_________________
Bartels.Schöne
ConPresso Support & Development
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Installation ConPresso 4 Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen