ConPresso Community

Fragen, Antworten, Diskussionen rund um das Content Management System ConPresso

 
CPO 3.4.7 und PHP =>5.5

 
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> laufender Betrieb ConPresso 3.x
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
joper
ConPresso-Newbie


Anmeldungsdatum: 10.01.2008
Beiträge: 6

BeitragVerfasst am: 11.01.2017 08:02    Titel: CPO 3.4.7 und PHP =>5.5 Antworten mit Zitat

Hallo zusammen,

ich habe noch eine alte 3.4.7 Seite auf PHP 5.2 laufen; der Provider macht jetzt eine Zwangsumstellung.

Ich habe hier im Forum diesen Thread gefunden http://community.conpresso.de/viewtopic.php?t=4695&lighter=, was aber die CPO4 betriftt, ergo betrifft es auch die CPO3.

Ich habe versucht mit der Änderung der Importvarialbe
Code:
if (!(bool)ini_get("register_globals")) {
   @extract($_COOKIE); @extract($_GET); @extract($_POST);
}


in der const.php meine Testseite (backup von Liveumgebung) wieder angezeigen zu lassen, was nicht funktioniert.

Testumgebung: PHP5.5/MsSQL 5.5
Bei PHP5.2 funktioniert die Seite!

Das Workaround für htmlspecialcharacter() müsste ich dann auch angehen, aber es scheitert schon an den Importvariablen.

Hat das einer schon mal ausprobiert und zum Laufen bekommen.
Dankbar für jede Idee/Anleitung.

Ich wollte die Seite an sich noch als "Archiv" aufrecht erhalten, und kein neues Projekt daraus machen.

Danke.
Jo.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 6944

BeitragVerfasst am: 11.01.2017 08:49    Titel: Antworten mit Zitat

Woran merkst Du dass es scheitert?
"funktioniert nicht" reicht nicht als Erläuterung der Bildschirmanzeigen und des Quelltextes sowie Auszüge aus den Log-Dateien.
Zitat:
Hat das einer schon mal ausprobiert und zum Laufen bekommen.

Ist das eine Frage?
Ich habe leider keine 3.x auf PHP 5.5 laufen, kann mich also nur nach Deinen Angaben richten.
Und ist die Angabe "MsSQL 5.5" richtig? Ist das ein IIS?

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
joper
ConPresso-Newbie


Anmeldungsdatum: 10.01.2008
Beiträge: 6

BeitragVerfasst am: 11.01.2017 11:09    Titel: CPO 3.4.7 und PHP =>5.5 Antworten mit Zitat

Sorry für die ungenauen Angaben.
Sollte eine Frage sein :
Zitat:
Hat das einer schon mal ausprobiert und zum Laufen bekommen?


Zur Datenbank: Das war ein Typfehler. Es is MySQL 5.5.2 (genau genommen), läuft auf Linux.

Ich habe die Seite mit verschiedenen PHP Versionen ab 5.4. bis 7.0 im CGI Mode, in der const.php mit den geänderten import_request_variablen, die Testseite http://sos-jagdhunde.de/home/index.php aufgerufen. Resultat: es wird kein html zurückgegeben. Leere Seite.

Gestestet : PHP =>5.4 bis 7.0

Bei PHP 5.2 wird die Seite normal anzeigt.
Ich erhalte zwar session_start Fehlermeldungen, liegt aber wohl daran, dass ich zum Testen der PHP Versionen die Produktiv-Seite und die DB 1:1 kopiert habe und nur die DB-Verbindung (Name, etc.) angepasst habe.

Gruß
Jo
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 6944

BeitragVerfasst am: 11.01.2017 12:17    Titel: Antworten mit Zitat

Da ich kein vergleichbares Testsystem habe mein Tipp zur Fehlersuche:

Durch Auskommentieren einzelner Zeilen versuchen den Problemcode einzukreisen.

Würde der Server ein Error-Log liefern wäre es viel einfacher, aber das bieten viele Provider nicht an.

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> laufender Betrieb ConPresso 3.x Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen