ConPresso Community

Fragen, Antworten, Diskussionen rund um das Content Management System ConPresso

 
Zerschossenes Layout... warum nur?
Gehe zu Seite 1, 2  Weiter
 
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Modul Guestbook (ConPresso 4)
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
JSchädler
ConPresso-User


Anmeldungsdatum: 03.10.2006
Beiträge: 37

BeitragVerfasst am: 29.06.2007 15:13    Titel: Zerschossenes Layout... warum nur? Antworten mit Zitat

Hallöchen miteinander.

Nachdem es mir neulich meine Datenbank zerschossen hat, dachte ich, wäre es endlich an der Zeit, aufs Conpresso4-Gästebuch umzustellen. Gesagt, getan. Und prompt stehe ich vor dem Problem, dass es mir mein Layout zerschießt und ich mir beim besten Willen nicht erklären kann, warum eigentlich. Die Tabellen, in denen das Gästebuch ja formatiert ist, scheinen für meine umgebenden div-Container gänzlich unsichtbar zu sein, sie fließen einfach drüber raus und in den nächsten Container rein (der sie dann komischerweise registriert...).
Ich wär euch dankbar, wenn ihr mal drüber schauen könntet. Das Modul ist frisch installiert, Templates und Einstellungen sind also unverändert. Lediglich die Header und Footer hab ich angepasst.

www.siambok.de/con4/mod_guestbook/

Falls ihr mehr Informationen braucht, lasst es mich wissen. Wahrscheinlich ist es was gaanz einfaches... wie immer... Rolling Eyes

Vielen Dank und viele Grüße
Julian
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Matthias V
Modul-Entwickler


Anmeldungsdatum: 01.01.1970
Beiträge: 1251
Wohnort: Sondershausen

BeitragVerfasst am: 29.06.2007 16:42    Titel: Antworten mit Zitat

Hübsches Internet Explorer-Problem, denn im Firefox funkioniert es weitgehend.

Du musst mal schauen, ob du irgendwelche falschen Verschachtelungen von HTML-Tags in deinem Layout (nicht im Template) hast.

Oder du nimmst ein Tabellenfreies Template. Ich hatte eben nur dieses mit Tabellen genommen, da diese noch relativ weit verbreitet sind und eigentlich immer funktionieren.
Ich habe das Template auch 10 mal überprüft, um mögliche Fehler rauszunehmen, bevor ich das Modul veröffentlicht habe.

Gruß Matthias V

Edit: Ich habe hier mal das von mir eingesetzte tabellenfreie Template rausgenommen, da Markus die richtige Lösung gefunden hat.

_________________
mod_Guestbook 4.1.0

Features:
- Einträge als ConPresso-Artikel
- benutzt Templates, Rubriken, ...
- Captcha
- BB-Code + Smilies + Zitieren
- Badwords
- Anonymisierung


Zuletzt bearbeitet von Matthias V am 30.06.2007 09:58, insgesamt einmal bearbeitet
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7011

BeitragVerfasst am: 29.06.2007 19:32    Titel: Antworten mit Zitat

Naja, wenn man die Tabellen auch als linksbündige Elemente formatiert...?

<table ... align="left">

setzt die Einträge schön nebeneinander.

Entferne align="left", dann passt das wieder.

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Matthias V
Modul-Entwickler


Anmeldungsdatum: 01.01.1970
Beiträge: 1251
Wohnort: Sondershausen

BeitragVerfasst am: 30.06.2007 00:35    Titel: Antworten mit Zitat

MarkusR hat Folgendes geschrieben:
Naja, wenn man die Tabellen auch als linksbündige Elemente formatiert...?

<table ... align="left">

setzt die Einträge schön nebeneinander.

Entferne align="left", dann passt das wieder.
Mist Embarassed , dann hätte ich ja doch was in meinem Template falsch.
Ich weiß schon, warum ich Tabellen nicht wirklich mag.

Das heißt so eine Angabe verhällt sich genauso, wie <table ... style="float: left;">

... Sch*** Tabellen Evil or Very Mad

Danke Markus, dass du solche Sachen findest.

Gruß Matthias V

_________________
mod_Guestbook 4.1.0

Features:
- Einträge als ConPresso-Artikel
- benutzt Templates, Rubriken, ...
- Captcha
- BB-Code + Smilies + Zitieren
- Badwords
- Anonymisierung
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7011

BeitragVerfasst am: 30.06.2007 07:19    Titel: Antworten mit Zitat

Matthias V hat Folgendes geschrieben:
Das heißt so eine Angabe verhällt sich genauso, wie <table ... style="float: left;">

Besser vergleichbar ist es mit
<img ... align="left">

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Matthias V
Modul-Entwickler


Anmeldungsdatum: 01.01.1970
Beiträge: 1251
Wohnort: Sondershausen

BeitragVerfasst am: 30.06.2007 09:52    Titel: Antworten mit Zitat

Also hier wurde es mit float: left; verglichen:
http://de.selfhtml.org/html/tabellen/umgebung.htm#ausrichtung

Außerdem wurde das umfließen mit clear: both; wieder gestoppt.

Gruß Matthias V

_________________
mod_Guestbook 4.1.0

Features:
- Einträge als ConPresso-Artikel
- benutzt Templates, Rubriken, ...
- Captcha
- BB-Code + Smilies + Zitieren
- Badwords
- Anonymisierung
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7011

BeitragVerfasst am: 02.07.2007 23:20    Titel: Antworten mit Zitat

Ich weiß jetzt nicht von wem im eigentlichen Formular die Zeile
Code:
<td colspan="0">

kommt, aber mit
Code:
<td colspan="2">

sähe es garantiert besser aus...

und natürlich sollte auch die Tabelle nicht linksbündig definiert sein, weil sonst der Link "zurück zum Gästebuch" arg im Nirvana steht...

_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
JSchädler
ConPresso-User


Anmeldungsdatum: 03.10.2006
Beiträge: 37

BeitragVerfasst am: 05.07.2007 09:51    Titel: Antworten mit Zitat

Huch... ich hab gar keine Infomails über Antworten gekriegt... peinlich.

Ähm ja. Das align="left" kommt von mir, weil die Tabelleninhalte auf einmal am rechten Rand klebten. Auch die colspan stand am Anfang auf 2, da hat sich bei der Veränderung überhaupt nichts getan. Im Firefox hab ich die Seite nicht angeschaut, ich benutz seit einiger Zeit Opera und überprüfe das Zeug im IE. Hat alles nicht so gut funktioniert...

Ich werds vielleicht mal tabellenfrei ausprobieren. Auf falsch verschachtelte Tags hab ich mein html schon ein paar mal überprüft und nix gefunden. Der Fehler liegt auch mit Sicherheit an mir, nicht am Modul (so ist zumindest meine Erfahrung bisher Smile ), aber ich finde ihn einfach nicht.

Ich probier nochmal rum, danke schon mal für eure Hilfe!

Lieben Gruß
Julian
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
JSchädler
ConPresso-User


Anmeldungsdatum: 03.10.2006
Beiträge: 37

BeitragVerfasst am: 05.07.2007 09:53    Titel: Antworten mit Zitat

Achso, noch mehr huch... wenn meine Veränderungen in den Templates natürlich noch drinstehen, ist das eh alles quatsch. Ich dachte, die hätte es bei der Neuinstallation zurückgesetzt. Dann mach ich das wohl nochmal...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Matthias V
Modul-Entwickler


Anmeldungsdatum: 01.01.1970
Beiträge: 1251
Wohnort: Sondershausen

BeitragVerfasst am: 05.07.2007 11:21    Titel: Antworten mit Zitat

Da bin ich ja beruhigt, dass ich das nicht ins Template geschrieben hatte.

Ich gebe bei der Deinstallation einen Hinweis aus, dass man das Template löschen sollte (denike ich). Und bei der Installation überprüfe ich ob schon ein Template mit dem Namen "Gästebuch (dein Modulverzeichis)" vorhanden ist, wenn ja nehme ich das, sonst wird ein neues Template installiert.

Dies ist der Grund, warum bei dir die Neuinstallation nicht das Original Template erzeugt hat.

Gruß Matthias V

P.S. Du findest das Standardtemplate hier: http://community.conpresso.de/viewtopic.php?t=3667, oder in der setup.php im Modulverzeichnis.

_________________
mod_Guestbook 4.1.0

Features:
- Einträge als ConPresso-Artikel
- benutzt Templates, Rubriken, ...
- Captcha
- BB-Code + Smilies + Zitieren
- Badwords
- Anonymisierung
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
JSchädler
ConPresso-User


Anmeldungsdatum: 03.10.2006
Beiträge: 37

BeitragVerfasst am: 05.07.2007 12:20    Titel: Antworten mit Zitat

Super, danke dir!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
marcusp
ConPresso-User


Anmeldungsdatum: 09.11.2006
Beiträge: 32

BeitragVerfasst am: 21.10.2008 16:38    Titel: Antworten mit Zitat

Hallo,
ich selbst habe auch ein Problem mit dem Layout. Je mehr einträgen zu sehen sind, desto schlimmer wird das Layout verschoben. Auf der Detail seite ist alles ok, aber in der Ansincht der Einträge wird mein Layout zerschossen.
Die Seite: http://www.feuerwehr-rahden.de/cms/mod_guestbook/index.php

FFür Hilfe bin ich dankbar!!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Mr. Magpie
ConPresso-Experte


Anmeldungsdatum: 01.01.1970
Beiträge: 996
Wohnort: Wuppertal

BeitragVerfasst am: 21.10.2008 16:53    Titel: Antworten mit Zitat

Layout?? Tut mir Leid, aber auf deinen Seiten sind dermaßen viele HTML-Fehler vorhanden, dass das Layout fast unkenntlich wird! Da macht es auch gar keinen Sinn (bitte nicht böse nehmen) eine Kleinigkeit zu korrigieren, denn bei so vielen Fehlern ist es höchst fraglich, ob jeder Browser diese auf gleiche Art umschifft oder toleriert.
_________________
Günther Ludwig, amazingBytes webdesign   

Referenzen finden Sie hier: amazingBytes webdesign - Referenzen
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
MarkusR
Handbuchversteher


Anmeldungsdatum: 01.01.1970
Beiträge: 7011

BeitragVerfasst am: 21.10.2008 18:35    Titel: Antworten mit Zitat

Fangen wir doch mal mit dem ersten und vielleicht entscheidenden Fehler an:

Code:
<hr color="#de4000>


ist nicht gut. Merke: was man öffnet muß man auch wieder schließen. Seien es HTML-Tags oder auch einfach nur öffnende Anführungszeichen, die nach schließenden Anführungszeichen verlangen, also

Code:
<hr color="#de4000">


Und nun besorge Dir bitte einen Editor mit Syntax-Highlighting wie Editplus oder Notepad++, dann mußt Du hier nicht solche Fragen stellen... Wink

Oder benutze zumindest die Quellcode-Ansicht von Firefox, weil Du schon dort farblich Deinen Fehler angezeigt bekommst...




Editplus
syntax.jpg
Klicken für Originalbild! syntax.jpg (142.45KB) - 502 mal angeklickt



_________________
Ciao Markus
ConPresso-Module
ConPresso und PHP 7

 
Für dieses Posting bedanken sich die folgenden User: marcusp
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
marcusp
ConPresso-User


Anmeldungsdatum: 09.11.2006
Beiträge: 32

BeitragVerfasst am: 22.10.2008 07:05    Titel: Antworten mit Zitat

Danke für die schnelle Hilfe. Hab den Wald vor lauter Bäumen nicht mehr gesehen. Einen neuen Editor hab ich mir gerade besorgt. Das hilft schon viel!

@Mr. Magpie:
Ich werde mir Deine Kritik zu Herzen nehmen. Bin für offene Worte dankbar und daher nicht böse. Wink
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neue Antwort erstellen    ConPresso Community Foren-Übersicht -> Modul Guestbook (ConPresso 4) Alle Zeiten sind GMT + 1 Stunde
Gehe zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen